<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>
	
	<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<meta name="og:title" content="STREET BEAT: In terms of development, what does South L.A. need the most?" />
<meta name="og:image" content="http://wavenewspapers.com/wp-content/uploads/2017/12/Fernando-Ruiz.jpg" />
<meta name="og:type" content="article" />
<meta name="og:description" content="Compiled by Billie Jordan in the Fairfax District.

[caption id=attachment_26569 align=alignnone width=241] YOLANDO BURTONSouth Central“Healthy grocery stores. We need Trader Joe’s, Whole Foods," />
<meta name="og:url" content="http://wavenewspapers.com/street-beat-terms-development-south-l-need/" />
	
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="shortcut icon" href="/favicon.ico" />
	<link rel="pingback" href="http://wavenewspapers.com/xmlrpc.php" />
		<!--[if IE 9]>
	<link rel="stylesheet" href="http://wavenewspapers.com/wp-content/themes/News/css/ie9.css" />
	<![endif]-->
	<!--[if lt IE 9]>
	<link rel="stylesheet" href="http://wavenewspapers.com/wp-content/themes/News/css/ie8.css" />
	<![endif]-->
	
		
	<!--[if lt IE 9]>
<script src="http://wavenewspapers.com/wp-content/themes/News/js/html5shiv.js"></script>
<script src="http://wavenewspapers.com/wp-content/themes/News/js/respond.js"></script>
<![endif]-->
	
			  
	
<style type="text/css">
	.gk-page { max-width: 1280px; }
		#gk-mainbody-columns > aside { width: 25%;}
	#gk-mainbody-columns > section { width: 75%; }
	#gk-mainbody-columns { background-position: 75% 0!important; }
		
		#gk-inset { width: 20%;}
	#gk-content-wrap { width: 80%; }
	#gk-mainbody-columns > section { background-position: 80% 0!important; }
		
		#gk-mainbody > div { width: 100%; }
		
</style>

	
		
			
	
		<script type="text/javascript">
		var thickboxL10n = {
			"next":"Next >",
			"prev":"< Prev",
			"image":"Image",
			"of":"of",
			"close":"Close",
			"noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.",
			"loadingAnimation":"http://wavenewspapers.com/wp-includes/js/thickbox/loadingAnimation.gif",
			"closeImage":"http://wavenewspapers.com/wp-includes/js/thickbox/tb-close.png"
		};
	</script>

		
<!-- This site is optimized with the Yoast SEO plugin v4.8 - https://yoast.com/wordpress/plugins/seo/ -->
<title>STREET BEAT: In terms of development, what does South L.A. need the most? - Wave Newspapers</title>
<link rel="canonical" href="http://wavenewspapers.com/street-beat-terms-development-south-l-need/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="STREET BEAT: In terms of development, what does South L.A. need the most? - Wave Newspapers" />
<meta property="og:description" content="Compiled by Billie Jordan in the Fairfax District.&hellip;" />
<meta property="og:url" content="http://wavenewspapers.com/street-beat-terms-development-south-l-need/" />
<meta property="og:site_name" content="Wave Newspapers" />
<meta property="article:tag" content="Development" />
<meta property="article:tag" content="South Los Angeles" />
<meta property="article:section" content="Opinion" />
<meta property="article:published_time" content="2017-12-01T14:49:45-08:00" />
<meta property="og:image" content="http://wavenewspapers.com/wp-content/uploads/2017/12/Fernando-Ruiz.jpg" />
<meta property="og:image:width" content="700" />
<meta property="og:image:height" content="853" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Wave Newspapers &raquo; Feed" href="http://wavenewspapers.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Wave Newspapers &raquo; Comments Feed" href="http://wavenewspapers.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Wave Newspapers &raquo; STREET BEAT: In terms of development, what does South L.A. need the most? Comments Feed" href="http://wavenewspapers.com/street-beat-terms-development-south-l-need/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/wavenewspapers.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='gavern-normalize-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/normalize.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-template-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/template.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-wp-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/wp.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-stuff-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/stuff.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-wpextensions-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/wp.extensions.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-extensions-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/extensions.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-typography-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/shortcodes.typography.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-elements-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/shortcodes.elements.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-template-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/shortcodes.template.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-desktop-small-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/desktop.small.css?ver=4.8.4' type='text/css' media='(max-width: 1230px)' />
<link rel='stylesheet' id='gavern-tablet-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/tablet.css?ver=4.8.4' type='text/css' media='(max-width: 1030px)' />
<link rel='stylesheet' id='gavern-tablet-small-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/tablet.small.css?ver=4.8.4' type='text/css' media='(max-width: 820px)' />
<link rel='stylesheet' id='gavern-mobile-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/mobile.css?ver=4.8.4' type='text/css' media='(max-width: 580px)' />
<link rel='stylesheet' id='gavern-style-css'  href='http://wavenewspapers.com/wp-content/themes/News/css/style1.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-thickbox-css'  href='http://wavenewspapers.com/wp-includes/js/thickbox/thickbox.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://wavenewspapers.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='events-manager-css'  href='http://wavenewspapers.com/wp-content/plugins/events-manager/includes/css/events_manager.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='fvp-frontend-css'  href='http://wavenewspapers.com/wp-content/plugins/featured-video-plus/styles/frontend.css?ver=2.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='http://wavenewspapers.com/wp-content/plugins/photo-gallery/css/bwg_frontend.css?ver=1.3.43' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_font-awesome-css'  href='http://wavenewspapers.com/wp-content/plugins/photo-gallery/css/font-awesome/font-awesome.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_mCustomScrollbar-css'  href='http://wavenewspapers.com/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.css?ver=1.3.43' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_sumoselect-css'  href='http://wavenewspapers.com/wp-content/plugins/photo-gallery/css/sumoselect.css?ver=3.0.2' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.2.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	var disableStr = 'ga-disable-UA-2912033-4';
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-2912033-4', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('set', 'anonymizeIp', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"http:\/\/wavenewspapers.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=6.2.0'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/ui/sortable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/wp-a11y.min.js?ver=4.8.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EM = {"ajaxurl":"http:\/\/wavenewspapers.com\/wp-admin\/admin-ajax.php","locationajaxurl":"http:\/\/wavenewspapers.com\/wp-admin\/admin-ajax.php?action=locations_search","firstDay":"1","locale":"en","dateFormat":"mm\/dd\/yy","ui_css":"http:\/\/wavenewspapers.com\/wp-content\/plugins\/events-manager\/includes\/css\/jquery-ui.min.css","show24hours":"0","is_ssl":"","bookingInProgress":"Please wait while the booking is being submitted.","tickets_save":"Save Ticket","bookingajaxurl":"http:\/\/wavenewspapers.com\/wp-admin\/admin-ajax.php","bookings_export_save":"Export Bookings","bookings_settings_save":"Save Settings","booking_delete":"Are you sure you want to delete?","booking_offset":"30","bb_full":"Sold Out","bb_book":"Book Now","bb_booking":"Booking...","bb_booked":"Booking Submitted","bb_error":"Booking Error. Try again?","bb_cancel":"Cancel","bb_canceling":"Canceling...","bb_cancelled":"Cancelled","bb_cancel_error":"Cancellation Error. Try again?","txt_search":"Search","txt_searching":"Searching...","txt_loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/events-manager/includes/js/events-manager.js?ver=5.7'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/featured-video-plus/js/jquery.fitvids.min.js?ver=master-2015-08'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fvpdata = {"ajaxurl":"http:\/\/wavenewspapers.com\/wp-admin\/admin-ajax.php","nonce":"a4045c0813","fitvids":"1","dynamic":"","overlay":"","opacity":"0.75","color":"b","width":"640"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/featured-video-plus/js/frontend.min.js?ver=2.3.3'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/photo-gallery/js/bwg_frontend.js?ver=1.3.43'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectsL10n = {"bwg_select_tag":"Select Tag","bwg_search":"Search"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.0.2'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/photo-gallery/js/jquery.mobile.js?ver=1.3.43'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=1.3.43'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.js?ver=0.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search."};
/* ]]> */
</script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/photo-gallery/js/bwg_gallery_box.js?ver=1.3.43'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/themes/News/js/widgets/slideshow.js?ver=4.8.4'></script>
<link rel='https://api.w.org/' href='http://wavenewspapers.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://wavenewspapers.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://wavenewspapers.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='http://wavenewspapers.com/?p=26567' />
<link rel="alternate" type="application/json+oembed" href="http://wavenewspapers.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwavenewspapers.com%2Fstreet-beat-terms-development-south-l-need%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://wavenewspapers.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwavenewspapers.com%2Fstreet-beat-terms-development-south-l-need%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.3 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-2 {  margin: 0 auto; }
	.g-3 { width:100%; max-width:219px; height:auto; margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<link href="http://wavenewspapers.com/?opensearch_description=1" title="Wave Newspapers" rel="search" type="application/opensearchdescription+xml" /><link rel="shortcut icon" href="http://wave.semhosting.net/wp-content/uploads/2012/09/favicon.ico" type="image/x-icon" />
	
	<link href="http://fonts.googleapis.com/css?family=Hammersmith+One" rel="stylesheet" type="text/css" /><style type="text/css">
body,
h1, h2, h3, h4, h5, h6,
#main-menu > li li,
.bigtitle h3.header,
.box.badge-new .box-title::after,
.box.badge-popular .box-title::after,
.box.badge-top .box-title::after,
.box.bigtitle .box-title { font-family: Arial, Helvetica, sans-serif; }

#gk-logo.text,
#main-menu > li,
#top-menu,
#gk-user-area,
.box .box-title,
.gk-tabs-nav,
.nsphover .gk-nsp-category { font-family: 'Hammersmith One'; }

</style>
	<script type="text/javascript">
           $GK_PAGE_URL = 'http://wavenewspapers.com';
           $GK_TMPL_URL = 'http://wavenewspapers.com/wp-content/themes/News';
           $GK_TMPL_NAME = 'news';
           $GK_MENU = [];
           $GK_MENU["mainmenu"] = [];
           $GK_MENU["mainmenu"]["animation"] = "width_height_opacity";
           $GK_MENU["mainmenu"]["animation_speed"] = "fast";
           $GK_MENU["topmenu"] = [];
           $GK_MENU["topmenu"]["animation"] = "none";
           $GK_MENU["topmenu"]["animation_speed"] = "normal";
           $GK_MENU["footermenu"] = [];
           $GK_MENU["footermenu"]["animation"] = "none";
           $GK_MENU["footermenu"]["animation_speed"] = "normal";
        </script>
		
		
		
	<style>
div.gk-nsp-art > a {
display: none !important;
}

div.gk-nsp-art > a:nth-of-type(1) {
display: block !important;
}

div.gk-nsp-art > a:nth-of-type(2) {
display: block !important;
}

.gk-post-meta li.author {
display: none !important;
}
</style></head>
<body class="post-template-default single single-post postid-26567 single-format-standard custom-background" data-mobile="true" data-tablet-width="1030">
	<header id="gk-page-top">
		<div class="gk-page">
						<h1>
				<a href="http://wavenewspapers.com" class="imageLogo"><img src="/wp-content/uploads/2014/09/wave-logo-trans.png" alt="" width="200" height="86" /></a>
			</h1>
						
							<ul id="main-menu" class="menu gk_normal"><li id="menu-item-1166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1166"><a href="http://wavenewspapers.com/category/news/">News</a>
<div class="sub-menu"><ul>
	<li id="menu-item-1169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1169"><a href="http://wavenewspapers.com/category/news/local/">Local News</a></li>
	<li id="menu-item-1170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1170"><a href="http://wavenewspapers.com/category/news/national_world/">National/State</a></li>
	<li id="menu-item-1167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1167"><a href="http://wavenewspapers.com/category/news/business/">Business</a></li>
	<li id="menu-item-1376" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1376"><a href="http://wavenewspapers.com/category/cheers/">Cheers</a></li>
	<li id="menu-item-1176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1176"><a href="http://wavenewspapers.com/category/eedition/">Print Editions</a></li>
	<li id="menu-item-1177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1177"><a href="http://wavenewspapers.com/category/multimedia/">Slideshows</a></li>
</ul></div>
</li>
<li id="menu-item-1178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1178"><a href="http://wavenewspapers.com/category/news/local/">Local Editions</a>
<div class="sub-menu"><ul>
	<li id="menu-item-1188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1188"><a href="http://wavenewspapers.com/category/news/local/northeast_edition/">Northeast Edition</a></li>
	<li id="menu-item-1184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1184"><a href="http://wavenewspapers.com/category/news/local/culver_city_edition/">Culver City Edition</a></li>
	<li id="menu-item-1187" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1187"><a href="http://wavenewspapers.com/category/news/local/lynwood_press/">Lynwood Press</a></li>
	<li id="menu-item-1190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1190"><a href="http://wavenewspapers.com/category/news/local/west_edition/">West Edition</a></li>
	<li id="menu-item-1185" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1185"><a href="http://wavenewspapers.com/category/news/local/east_edition/">East Edition</a></li>
	<li id="menu-item-1186" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1186"><a href="http://wavenewspapers.com/category/news/local/herald_american/">Herald American</a></li>
	<li id="menu-item-1189" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1189"><a href="http://wavenewspapers.com/category/news/local/the_press/">The Press</a></li>
</ul></div>
</li>
<li id="menu-item-1180" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1180"><a href="http://wavenewspapers.com/category/arts_and_entertainment/">Entertainment</a>
<div class="sub-menu"><ul>
	<li id="menu-item-1378" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1378"><a href="http://wavenewspapers.com/category/arts_and_entertainment/tasty_clips/">Tasty Clips</a></li>
	<li id="menu-item-5212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5212"><a href="http://wavenewspapers.com/category/arts_and_entertainment/simplyjessica/">SImply Jessica</a></li>
	<li id="menu-item-6737" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6737"><a href="http://wavenewspapers.com/category/arts_and_entertainment/photogalleries/">Photo Galleries</a></li>
	<li id="menu-item-20071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20071"><a href="http://wavenewspapers.com/category/arts_and_entertainment/book-corner/">Book Corner</a></li>
</ul></div>
</li>
<li id="menu-item-1182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1182"><a href="http://wavenewspapers.com/category/sports/">Sports</a>
<div class="sub-menu"><ul>
	<li id="menu-item-1196" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1196"><a href="http://wavenewspapers.com/category/sports/prep/">Prep</a></li>
	<li id="menu-item-1195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1195"><a href="http://wavenewspapers.com/category/sports/college/">College</a></li>
	<li id="menu-item-1197" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1197"><a href="http://wavenewspapers.com/category/sports/professional/">Professional</a></li>
</ul></div>
</li>
<li id="menu-item-1181" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-1181"><a href="http://wavenewspapers.com/category/opinion/">Opinion</a>
<div class="sub-menu"><ul>
	<li id="menu-item-1379" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1379"><a href="http://wavenewspapers.com/category/opinion/columnists/">Columnists</a></li>
	<li id="menu-item-1380" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1380"><a href="http://wavenewspapers.com/category/opinion/earl_ofari_hutchinson/">Earl Ofari Hutchinson</a></li>
	<li id="menu-item-1381" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1381"><a href="http://wavenewspapers.com/category/opinion/lekan_oguntoyinbo/">Lekan Oguntoyinbo</a></li>
	<li id="menu-item-1382" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1382"><a href="http://wavenewspapers.com/category/opinion/mamas_boyz/">Mamas Boyz</a></li>
	<li id="menu-item-1383" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1383"><a href="http://wavenewspapers.com/category/opinion/mayor_eric_garcetti/">Mayor Eric Garcetti</a></li>
	<li id="menu-item-8887" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-8887"><a href="http://wavenewspapers.com/category/opinion/blogs/">Blogs</a>
	<div class="sub-menu"><ul>
		<li id="menu-item-8888" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8888"><a href="http://wavenewspapers.com/category/opinion/blogs/najees-notes/">Najee&#8217;s Notes</a></li>
	</ul></div>
</li>
	<li id="menu-item-1384" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1384"><a href="http://wavenewspapers.com/category/opinion/street_beat/">Street Beat</a></li>
</ul></div>
</li>
<li id="menu-item-1394" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1394"><a href="http://wavenewspapers.com/category/video/">Video</a></li>
<li id="menu-item-6194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6194"><a href="http://wavenewspapers.com/category/food/">Food</a></li>
<li id="menu-item-1392" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1392"><a href="http://wavenewspapers.com/category/advertising/">Advertising</a></li>
<li id="menu-item-2797" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2797"><a href="http://wavenewspapers.com/submissions/">Submit A News Item</a></li>
<li id="menu-item-1461" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1461"><a href="http://wavenewspapers.com/category/featured/">Featured</a></li>
</ul>				<div id="main-menu-mobile" class="menu-{menu slug}-container"><select onchange="window.location.href=this.value;"><option value="#">Select a page</option><option value="http://wavenewspapers.com/category/news/"> News</option><option value="http://wavenewspapers.com/category/news/local/">&mdash; Local News</option><option value="http://wavenewspapers.com/category/news/national_world/">&mdash; National/State</option><option value="http://wavenewspapers.com/category/news/business/">&mdash; Business</option><option value="http://wavenewspapers.com/category/cheers/">&mdash; Cheers</option><option value="http://wavenewspapers.com/category/eedition/">&mdash; Print Editions</option><option value="http://wavenewspapers.com/category/multimedia/">&mdash; Slideshows</option><option value="http://wavenewspapers.com/category/news/local/"> Local Editions</option><option value="http://wavenewspapers.com/category/news/local/northeast_edition/">&mdash; Northeast Edition</option><option value="http://wavenewspapers.com/category/news/local/culver_city_edition/">&mdash; Culver City Edition</option><option value="http://wavenewspapers.com/category/news/local/lynwood_press/">&mdash; Lynwood Press</option><option value="http://wavenewspapers.com/category/news/local/west_edition/">&mdash; West Edition</option><option value="http://wavenewspapers.com/category/news/local/east_edition/">&mdash; East Edition</option><option value="http://wavenewspapers.com/category/news/local/herald_american/">&mdash; Herald American</option><option value="http://wavenewspapers.com/category/news/local/the_press/">&mdash; The Press</option><option value="http://wavenewspapers.com/category/arts_and_entertainment/"> Entertainment</option><option value="http://wavenewspapers.com/category/arts_and_entertainment/tasty_clips/">&mdash; Tasty Clips</option><option value="http://wavenewspapers.com/category/arts_and_entertainment/simplyjessica/">&mdash; SImply Jessica</option><option value="http://wavenewspapers.com/category/arts_and_entertainment/photogalleries/">&mdash; Photo Galleries</option><option value="http://wavenewspapers.com/category/arts_and_entertainment/book-corner/">&mdash; Book Corner</option><option value="http://wavenewspapers.com/category/sports/"> Sports</option><option value="http://wavenewspapers.com/category/sports/prep/">&mdash; Prep</option><option value="http://wavenewspapers.com/category/sports/college/">&mdash; College</option><option value="http://wavenewspapers.com/category/sports/professional/">&mdash; Professional</option><option value="http://wavenewspapers.com/category/opinion/"> Opinion</option><option value="http://wavenewspapers.com/category/opinion/columnists/">&mdash; Columnists</option><option value="http://wavenewspapers.com/category/opinion/earl_ofari_hutchinson/">&mdash; Earl Ofari Hutchinson</option><option value="http://wavenewspapers.com/category/opinion/lekan_oguntoyinbo/">&mdash; Lekan Oguntoyinbo</option><option value="http://wavenewspapers.com/category/opinion/mamas_boyz/">&mdash; Mamas Boyz</option><option value="http://wavenewspapers.com/category/opinion/mayor_eric_garcetti/">&mdash; Mayor Eric Garcetti</option><option value="http://wavenewspapers.com/category/opinion/blogs/">&mdash; Blogs</option><option value="http://wavenewspapers.com/category/opinion/blogs/najees-notes/">&mdash;&mdash; Najee&#8217;s Notes</option><option value="http://wavenewspapers.com/category/opinion/street_beat/">&mdash; Street Beat</option><option value="http://wavenewspapers.com/category/video/"> Video</option><option value="http://wavenewspapers.com/category/food/"> Food</option><option value="http://wavenewspapers.com/category/advertising/"> Advertising</option><option value="http://wavenewspapers.com/submissions/"> Submit A News Item</option><option value="http://wavenewspapers.com/category/featured/"> Featured</option></select></div>						
						<div id="gk-user-area">
								<a href="wp-login.php?action=login" id="gk-login">Login</a>
								
								<a href="#" id="gk-rss">RSS</a>
							</div>
					</div>
	</header>


<section id="gk-content-top" class="gk-page">
		
		<div id="gk-social-icons">
		<a href="https://www.twitter.com/LA_WaveNews" class="gk-twitter-icon">Twitter</a><a href="https://www.facebook.com/LosAngelesWave" class="gk-facebook-icon">Facebook</a><a href="https://www.pinterest.com/wavenews/" class="gk-pinterest-icon">Pinterest</a><a href="https://plus.google.com/106297564948888718594/" class="gk-gplus-icon">Google+</a>	</div>
		
		<div id="gk-search">
		
<form method="get" id="searchform" action="http://wavenewspapers.com/">
	<label for="s">Search</label>
	<input type="text" class="field" name="s" id="s" placeholder="Search" value="" />
	
	<input type="submit" id="searchsubmit" value="Search" />
</form>	</div>
		
	<!--[if IE 8]>
	<div class="ie8clear"></div>
	<![endif]-->
</section>

<div class="gk-page-wrap gk-page">
	<div id="gk-mainbody-columns">			
		<section>
			<div id="gk-content-wrap">
								<div id="gk-top1">
					<div class="gk-page widget-area">
						<div id="adrotate_widgets-2" class="box  advertisement all adrotate_widgets col4 nth1 last1"><!-- Either there are no banners, they are disabled or none qualified for this location! --></div>					</div>
					<!--[if IE 8]>
					<div class="ie8clear"></div>
					<![endif]-->
				</div>
								
								
				<!-- Mainbody, breadcrumbs -->
								<div id="gk-breadcrumb-area">
					<nav class="gk-breadcrumbs"><a href="http://wavenewspapers.com" class="gk-home">Wave Newspapers</a><a href="http://wavenewspapers.com/category/opinion/" rel="category tag">Opinion</a> <a href="http://wavenewspapers.com/category/opinion/street_beat/" rel="category tag">Street Beat</a><span class="gk-current">STREET BEAT: In terms of development, what does South L.A. need the most?</span></nav>					<!--[if IE 8]>
					<div class="ie8clear"></div>
					<![endif]-->
				</div>
								
							
<section id="gk-mainbody">
	<div>
					
	<article id="post-26567" class="post-26567 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion category-street_beat tag-development tag-south-los-angeles">
		<header>
			
<h1>
			STREET BEAT: In terms of development, what does South L.A. need the most?		
	</h1>

						 		
		<ul class="meta">
				
				<li>
			<time class="entry-date" datetime="2017-12-01T14:49:45-08:00">
				December 1, 2017			</time>
	 	</li>
	 		 	
	 		 	<li>
	 		Written by:	 		
	 		<a class="url fn n" href="http://wavenewspapers.com/author/don-wanlass/" title="View all posts by posted by Wave Staff" rel="author">posted by Wave Staff</a>
	 	</li>
	 		 	
	 		 </ul> 	
	  				
		</header>
		
		
		<figure class="featured-image">
		<img width="700" height="853" src="http://wavenewspapers.com/wp-content/uploads/2017/12/Fernando-Ruiz.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://wavenewspapers.com/wp-content/uploads/2017/12/Fernando-Ruiz.jpg 700w, http://wavenewspapers.com/wp-content/uploads/2017/12/Fernando-Ruiz-246x300.jpg 246w" sizes="(max-width: 700px) 100vw, 700px" />		
					<figcaption>FERNANDO RUIZ
Los Angeles
“I would probably say affordable housing and then better schools; they go hand and hand. If the housing is not good, the schools are not going to be good.”
</figcaption>			</figure>
			
				<aside class="gk-post-meta">
	<ul>
				<li>
			Category:			<a href="http://wavenewspapers.com/category/opinion/" rel="category tag">Opinion</a>, <a href="http://wavenewspapers.com/category/opinion/street_beat/" rel="category tag">Street Beat</a>		</li>
				 	
		<li>
			<a href="http://wavenewspapers.com/street-beat-terms-development-south-l-need/" title="Permalink to STREET BEAT: In terms of development, what does South L.A. need the most?" rel="bookmark">permalink</a>
			
				
		</li>
			
				<li class="tags">
			<p>Tagged under:</p>
			<a href="http://wavenewspapers.com/tag/development/" rel="tag">Development</a>, <a href="http://wavenewspapers.com/tag/south-los-angeles/" rel="tag">South Los Angeles</a>		</li>
				
				
							    <li class="author">
		        		        
                <a href="http://wavenewspapers.com/author/don-wanlass/" class="gk-author-name" rel="author">
                    Don Wanlass 
                </a>
	               
	            		            
	            		    </li>
		    			</ul>
</aside>
			
		<section class="content">
			<p><strong><em>Compiled by Billie Jordan in the Fairfax District.</em></strong></p>
<div id="attachment_26569" style="width: 251px" class="wp-caption alignnone"><a href="http://wavenewspapers.com/wp-content/uploads/2017/12/Yolanda-Burton.jpg"><img class="size-medium wp-image-26569" src="http://wavenewspapers.com/wp-content/uploads/2017/12/Yolanda-Burton-241x300.jpg" alt="" width="241" height="300" srcset="http://wavenewspapers.com/wp-content/uploads/2017/12/Yolanda-Burton-241x300.jpg 241w, http://wavenewspapers.com/wp-content/uploads/2017/12/Yolanda-Burton.jpg 700w" sizes="(max-width: 241px) 100vw, 241px" /></a><p class="wp-caption-text">YOLANDO BURTON<br />South Central<br />“Healthy grocery stores. We need Trader Joe’s, Whole Foods, Sprouts; we need stores like that in our neighborhood.”</p></div>
<div id="attachment_26570" style="width: 247px" class="wp-caption alignnone"><a href="http://wavenewspapers.com/wp-content/uploads/2017/12/Phillip-Adams.jpg"><img class="size-medium wp-image-26570" src="http://wavenewspapers.com/wp-content/uploads/2017/12/Phillip-Adams-237x300.jpg" alt="" width="237" height="300" srcset="http://wavenewspapers.com/wp-content/uploads/2017/12/Phillip-Adams-237x300.jpg 237w, http://wavenewspapers.com/wp-content/uploads/2017/12/Phillip-Adams.jpg 700w" sizes="(max-width: 237px) 100vw, 237px" /></a><p class="wp-caption-text">PHILLIP ADAMS<br />Mid-City<br />“Better schools and law enforcement that will actually work with the community not against us.”</p></div>
<div id="attachment_26571" style="width: 229px" class="wp-caption alignnone"><a href="http://wavenewspapers.com/wp-content/uploads/2017/12/Greg-Johnson.jpg"><img class="size-medium wp-image-26571" src="http://wavenewspapers.com/wp-content/uploads/2017/12/Greg-Johnson-219x300.jpg" alt="" width="219" height="300" srcset="http://wavenewspapers.com/wp-content/uploads/2017/12/Greg-Johnson-219x300.jpg 219w, http://wavenewspapers.com/wp-content/uploads/2017/12/Greg-Johnson.jpg 700w" sizes="(max-width: 219px) 100vw, 219px" /></a><p class="wp-caption-text">GREG JOHNSON<br />Los Angeles<br />“Financial literacy. It’s a huge subject that’s missing from the educational landscape in South Los Angeles.”</p></div>
<div id="attachment_26572" style="width: 254px" class="wp-caption alignnone"><a href="http://wavenewspapers.com/wp-content/uploads/2017/12/Karen-B.jpg"><img class="size-medium wp-image-26572" src="http://wavenewspapers.com/wp-content/uploads/2017/12/Karen-B-244x300.jpg" alt="" width="244" height="300" srcset="http://wavenewspapers.com/wp-content/uploads/2017/12/Karen-B-244x300.jpg 244w, http://wavenewspapers.com/wp-content/uploads/2017/12/Karen-B.jpg 700w" sizes="(max-width: 244px) 100vw, 244px" /></a><p class="wp-caption-text">KAREN B.<br />Los Angeles<br />“Help the homeless because the homeless are everywhere now and it&#8217;s not getting any better. They are building all these apartments, but nobody can afford them. The rents are too high and it&#8217;s ridiculous.”</p></div>
<div id="attachment_26573" style="width: 213px" class="wp-caption alignnone"><a href="http://wavenewspapers.com/wp-content/uploads/2017/12/Pam-Perkins.jpg"><img class="size-medium wp-image-26573" src="http://wavenewspapers.com/wp-content/uploads/2017/12/Pam-Perkins-203x300.jpg" alt="" width="203" height="300" srcset="http://wavenewspapers.com/wp-content/uploads/2017/12/Pam-Perkins-203x300.jpg 203w, http://wavenewspapers.com/wp-content/uploads/2017/12/Pam-Perkins-695x1024.jpg 695w, http://wavenewspapers.com/wp-content/uploads/2017/12/Pam-Perkins.jpg 700w" sizes="(max-width: 203px) 100vw, 203px" /></a><p class="wp-caption-text">PAM PERKINS<br />Los Angeles<br />“Improvement in schools; more teachers and less students to each teacher.”</p></div>
<div id="attachment_26574" style="width: 240px" class="wp-caption alignnone"><a href="http://wavenewspapers.com/wp-content/uploads/2017/12/Monique-headles.jpg"><img class="size-medium wp-image-26574" src="http://wavenewspapers.com/wp-content/uploads/2017/12/Monique-headles-230x300.jpg" alt="" width="230" height="300" srcset="http://wavenewspapers.com/wp-content/uploads/2017/12/Monique-headles-230x300.jpg 230w, http://wavenewspapers.com/wp-content/uploads/2017/12/Monique-headles.jpg 700w" sizes="(max-width: 230px) 100vw, 230px" /></a><p class="wp-caption-text">MONIQUE HEADLES<br />Los Angeles<br />“We need help with the homeless problem. We are one of the largest cities and I think we have the biggest homeless problem.”</p></div>
<div id="attachment_26575" style="width: 255px" class="wp-caption alignnone"><a href="http://wavenewspapers.com/wp-content/uploads/2017/12/Jewel-Ferguson.jpg"><img class="size-medium wp-image-26575" src="http://wavenewspapers.com/wp-content/uploads/2017/12/Jewel-Ferguson-245x300.jpg" alt="" width="245" height="300" srcset="http://wavenewspapers.com/wp-content/uploads/2017/12/Jewel-Ferguson-245x300.jpg 245w, http://wavenewspapers.com/wp-content/uploads/2017/12/Jewel-Ferguson.jpg 700w" sizes="(max-width: 245px) 100vw, 245px" /></a><p class="wp-caption-text">JEWEL FERGUSON<br />Inglewood<br />“Affordable housing, higher wages and parks with outside exercise equipment.”</p></div>
			
								</section>
				
		

		
		</article>					
			

			
						</div>
	
	
</section>

		
							</div><!-- end of the #gk-content-wrap -->
			
									<aside id="gk-inset">
				<div id="bwp_gallery-2" class="box  bwp_gallery"><h3 class="box-title">Comic Con 2015 Gallery</h3><style>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</style>    <div id="bwg_container1_0">
      <div id="bwg_container2_0">
        <form id="gal_front_form_0" method="post" action="#" data-current="0">
                    <div style="background-color:rgba(0, 0, 0, 0); text-align: center; width:100%; position: relative;">
            <div id="ajax_loading_0" style="position:absolute;width: 100%; z-index: 115; text-align: center; height: 100%; vertical-align: middle; display:none;">
              <div style="display: table; vertical-align: middle; width: 100%; height: 100%; background-color: #FFFFFF; opacity: 0.7; filter: Alpha(opacity=70);">
                <div style="display: table-cell; text-align: center; position: relative; vertical-align: middle;" >
                  <div id="loading_div_0" class="bwg_spider_ajax_loading" style="display: inline-block; text-align:center; position:relative; vertical-align:middle; background-image:url(http://wavenewspapers.com/wp-content/plugins/photo-gallery/images/ajax_loader.gif); float: none; width:30px;height:30px;background-size:30px 30px;">
                  </div>
                </div>
              </div>
            </div>
                        <div id="bwg_standart_thumbnails_0" class="bwg_standart_thumbnails_0">
                              <a  class="bwg_lightbox_0" href="http://wavenewspapers.com/wp-content/uploads/photo-gallery/IMG_7795.jpg" data-image-id="37">
                  <span class="bwg_standart_thumb_0">
                                        <span class="bwg_standart_thumb_spun1_0">
                      <span class="bwg_standart_thumb_spun2_0">
                                                <img class="bwg_standart_thumb_img_0 bwg_img_clear bwg_img_custom" style="width:100px; height:133.33333333333px; margin-left: 0px; margin-top: -16.666666666667px;" id="37" src="http://wavenewspapers.com/wp-content/uploads/photo-gallery/thumb/IMG_7795.jpg" alt="SDCC05" />
                      </span>
                    </span>
                                      </span>
                </a>
                                <a  class="bwg_lightbox_0" href="http://wavenewspapers.com/wp-content/uploads/photo-gallery/IMG_7660.jpg" data-image-id="21">
                  <span class="bwg_standart_thumb_0">
                                        <span class="bwg_standart_thumb_spun1_0">
                      <span class="bwg_standart_thumb_spun2_0">
                                                <img class="bwg_standart_thumb_img_0 bwg_img_clear bwg_img_custom" style="width:133.33333333333px; height:100px; margin-left: -16.666666666667px; margin-top: 0px;" id="21" src="http://wavenewspapers.com/wp-content/uploads/photo-gallery/thumb/IMG_7660.jpg" alt="SDCC21" />
                      </span>
                    </span>
                                      </span>
                </a>
                                <a  class="bwg_lightbox_0" href="http://wavenewspapers.com/wp-content/uploads/photo-gallery/IMG_7763.jpg" data-image-id="35">
                  <span class="bwg_standart_thumb_0">
                                        <span class="bwg_standart_thumb_spun1_0">
                      <span class="bwg_standart_thumb_spun2_0">
                                                <img class="bwg_standart_thumb_img_0 bwg_img_clear bwg_img_custom" style="width:100px; height:133.33333333333px; margin-left: 0px; margin-top: -16.666666666667px;" id="35" src="http://wavenewspapers.com/wp-content/uploads/photo-gallery/thumb/IMG_7763.jpg" alt="SDCC07" />
                      </span>
                    </span>
                                      </span>
                </a>
                                <a  class="bwg_lightbox_0" href="http://wavenewspapers.com/wp-content/uploads/photo-gallery/IMG_7610.jpg" data-image-id="13">
                  <span class="bwg_standart_thumb_0">
                                        <span class="bwg_standart_thumb_spun1_0">
                      <span class="bwg_standart_thumb_spun2_0">
                                                <img class="bwg_standart_thumb_img_0 bwg_img_clear bwg_img_custom" style="width:133.33333333333px; height:100px; margin-left: -16.666666666667px; margin-top: 0px;" id="13" src="http://wavenewspapers.com/wp-content/uploads/photo-gallery/thumb/IMG_7610.jpg" alt="SDCC28" />
                      </span>
                    </span>
                                      </span>
                </a>
                            </div>
                      </div>
        </form>
        <div id="bwg_spider_popup_loading_0" class="bwg_spider_popup_loading"></div>
        <div id="spider_popup_overlay_0" class="spider_popup_overlay" onclick="spider_destroypopup(1000)"></div>
      </div>
    </div>
    <script>
            function bwg_gallery_box_0(image_id) {
        var filterTags = jQuery("#bwg_tags_id_bwg_standart_thumbnails_0" ).val() ? jQuery("#bwg_tags_id_bwg_standart_thumbnails_0" ).val() : 0;
        var filtersearchname = jQuery("#bwg_search_input_0" ).val() ? "&filter_search_name_0=" + jQuery("#bwg_search_input_0" ).val() : '';
        spider_createpopup('http://wavenewspapers.com/wp-admin/admin-ajax.php?action=GalleryBox&tags=0&current_view=0&gallery_id=2&theme_id=1&thumb_width=100&thumb_height=100&open_with_fullscreen=0&open_with_autoplay=0&image_width=800&image_height=500&image_effect=fade&wd_sor=order&wd_ord=asc&enable_image_filmstrip=1&image_filmstrip_height=70&enable_image_ctrl_btn=1&enable_image_fullscreen=1&popup_enable_info=1&popup_info_always_show=0&popup_info_full_width=0&popup_hit_counter=0&popup_enable_rate=0&slideshow_interval=5&enable_comment_social=1&enable_image_facebook=1&enable_image_twitter=1&enable_image_google=1&enable_image_pinterest=0&enable_image_tumblr=0&watermark_type=none&slideshow_effect_duration=1&image_id=' + image_id + "&filter_tag_0=" +  filterTags + filtersearchname, '0', '800', '500', 1, 'testpopup', 5, "bottom");
      }
      function bwg_document_ready_0() {
        var bwg_touch_flag = false;
        jQuery(".bwg_lightbox_0").on("click", function () {
          if (!bwg_touch_flag) {
            bwg_touch_flag = true;
            setTimeout(function(){ bwg_touch_flag = false; }, 100);
            bwg_gallery_box_0(jQuery(this).attr("data-image-id"));
            return false;
          }
        });
               }
      jQuery(document).ready(function () {
        bwg_document_ready_0();
      });
    </script>
    </div><div id="widget_gk_nsp-7" class="box  arrows bigtitle color onlylinks all widget_gk_nsp"><h3 class="box-title">Sports</h3><div class="gk-nsp" data-cols="" data-rows="" data-links="5" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-"></div></div><div class="gk-nsp-links"><div class="gk-nsp-links-scroll gk-nsp-pages-1"><ul class="gk-nsp-list gk-nsp-cols-1"><li><h4 class="gk-nsp-link-header"><a href="http://wavenewspapers.com/sports-digest-chip-kelly-good-choice-ucla-football/" title="SPORTS DIGEST: Chip Kelly is good choice for UCLA football">SPORTS DIGEST: Chip Kelly is good choice for UCLA&hellip;</a></h4><p class="gk-nsp-link-text">This is such a busy time&hellip;</p></li><li><h4 class="gk-nsp-link-header"><a href="http://wavenewspapers.com/prep-football-six-area-schools-play-football-championships/" title="PREP FOOTBALL: Six area schools to play for football championships">PREP FOOTBALL: Six area schools to play for football&hellip;</a></h4><p class="gk-nsp-link-text">Six area high school football teams&hellip;</p></li><li><h4 class="gk-nsp-link-header"><a href="http://wavenewspapers.com/great-week-football-los-angeles-fans/" title="Great week of football for Los Angeles fans">Great week of football for Los Angeles fans</a></h4><p class="gk-nsp-link-text">Week 11 in the National Football&hellip;</p></li><li><h4 class="gk-nsp-link-header"><a href="http://wavenewspapers.com/sports-digest-just-like-old-times-minnesota-vikings-beat-rams/" title="SPORTS DIGEST: Just like old times, Minnesota Vikings beat the Rams">SPORTS DIGEST: Just like old times, Minnesota Vikings beat&hellip;</a></h4><p class="gk-nsp-link-text">Just when I was thinking about&hellip;</p></li><li><h4 class="gk-nsp-link-header"><a href="http://wavenewspapers.com/prep-football-14-area-teams-advance-playoff-semifinals/" title="PREP FOOTBALL: 14 area teams advance to playoff semifinals">PREP FOOTBALL: 14 area teams advance to playoff semifinals</a></h4><p class="gk-nsp-link-text">Several area high school football teams&hellip;</p></li></ul></div></div></div></div>			</aside>
								</section><!-- end of the mainbody section -->
	
						<aside id="gk-sidebar">
			<div id="adrotate_widgets-3" class="box  advertisement all adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></div><div id="em_calendar-2" class="box  color all widget_em_calendar"><h3 class="box-title">Events Calendar</h3><div id="em-calendar-147" class="em-calendar-wrapper"><table class="em-calendar">
	<thead>
		<tr>
			<td><a class="em-calnav em-calnav-prev" href="/street-beat-terms-development-south-l-need/?ajaxCalendar=1&#038;mo=11&#038;yr=2017" rel="nofollow">&lt;&lt;</a></td>
			<td class="month_name" colspan="5">Dec 2017</td>
			<td><a class="em-calnav em-calnav-next" href="/street-beat-terms-development-south-l-need/?ajaxCalendar=1&#038;mo=1&#038;yr=2018" rel="nofollow">&gt;&gt;</a></td>
		</tr>
	</thead>
	<tbody>
		<tr class="days-names">
			<td>M</td><td>T</td><td>W</td><td>T</td><td>F</td><td>S</td><td>S</td>
		</tr>
		<tr>
							<td class="eventless-pre">
										27									</td>
								<td class="eventless-pre">
										28									</td>
								<td class="eventless-pre">
										29									</td>
								<td class="eventless-pre">
										30									</td>
								<td class="eventless">
										1									</td>
								<td class="eventless-today">
										2									</td>
								<td class="eventless">
										3									</td>
				</tr><tr>				<td class="eventless">
										4									</td>
								<td class="eventless">
										5									</td>
								<td class="eventless">
										6									</td>
								<td class="eventless">
										7									</td>
								<td class="eventless">
										8									</td>
								<td class="eventless">
										9									</td>
								<td class="eventless">
										10									</td>
				</tr><tr>				<td class="eventless">
										11									</td>
								<td class="eventless">
										12									</td>
								<td class="eventless">
										13									</td>
								<td class="eventless">
										14									</td>
								<td class="eventless">
										15									</td>
								<td class="eventless">
										16									</td>
								<td class="eventless">
										17									</td>
				</tr><tr>				<td class="eventless">
										18									</td>
								<td class="eventless">
										19									</td>
								<td class="eventless">
										20									</td>
								<td class="eventless">
										21									</td>
								<td class="eventless">
										22									</td>
								<td class="eventless">
										23									</td>
								<td class="eventless">
										24									</td>
				</tr><tr>				<td class="eventless">
										25									</td>
								<td class="eventless">
										26									</td>
								<td class="eventless">
										27									</td>
								<td class="eventless">
										28									</td>
								<td class="eventless">
										29									</td>
								<td class="eventless">
										30									</td>
								<td class="eventless">
										31									</td>
						</tr>
	</tbody>
</table></div></div><div id="text-33" class="box  widget_text">			<div class="textwidget"><div align="center"><a href="http://wavenewspapers.com/events/"><button>See All Events</button></a><br>
<a href="http://wavenewspapers.com/add-an-event/?action=edit"><button>Add An Event</button></a></div></div>
		</div><div id="advancedcustomfacebooklikeboxwidget-2" class="box  widget_advancedcustomfacebooklikeboxwidget"><h3 class="box-title">Follow Us On Facebook</h3>
            <script>(function(d, s, id) {
                var js, fjs = d.getElementsByTagName(s)[0];
                if (d.getElementById(id)) return;
                js = d.createElement(s); js.id = id;
                js.src = '//connect.facebook.net/en_US/all.js#xfbml=1';
                fjs.parentNode.insertBefore(js, fjs);
              }(document, 'script', 'facebook-jssdk'));
             </script>
  
<div id='advanced_facebook_likebox_widget' class='' style='max-width: 200px;'>
		<div class='fbCustom' style='background:#ffffff; width:200px; padding: 15px; border: 2px solid transparent; border-radius: 15px;'>
        <div class='FBWrap' style='height:356px; overflow: hidden;'>
            <div class='fb-like-box'
                data-width='200' data-height='356' 
                data-href='https://www.facebook.com/LosAngelesWave'
                data-border-color='transparent' data-show-faces='true'
                data-stream='false' data-header='false' data-color-scheme='light'>
            </div>
         </div><div style='font-size: 9px; color: #808080; font-weight: normal; font-family: tahoma,verdana,arial,sans-serif; line-height: 1.28; text-align: right; direction: ltr;'><a href='http://www.liveherechicago.com' target='_blank' style='color: #808080;' title='more info...'>liveherechicago.com</a></div></div></div></div><div id="widget_gk_nsp-8" class="box  badge-popular all widget_gk_nsp"><h3 class="box-title">Entertainment</h3><div class="gk-nsp mobile_layout" data-cols="1" data-rows="1" data-links="4" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="http://wavenewspapers.com/book-corner-author-shares-story-female-circumcision/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="http://wavenewspapers.com/wp-content/themes/News/gavern/cache_nsp/Elizabeth-Yaba-Book-Cover-copy-widget_gk_nsp-8.jpg" alt="" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="http://wavenewspapers.com/book-corner-author-shares-story-female-circumcision/" title="BOOK CORNER: Author shares her story about female circumcision">BOOK CORNER: Author shares her story about female circumcision</a></h3></div></div></div></div><div class="gk-nsp-links"><div class="gk-nsp-links-scroll gk-nsp-pages-1"><ul class="gk-nsp-list gk-nsp-cols-1"><li><h4 class="gk-nsp-link-header"><a href="http://wavenewspapers.com/bill-vaughans-tasty-clips-greys-anatomy-record-breaking-role-james-pickens-jr/" title="BILL VAUGHAN'S TASTY CLIPS: ‘Grey’s Anatomy’ is record-breaking role for James Pickens Jr.">BILL VAUGHAN'S TASTY CLIPS: ‘Grey’s Anatomy’ is record-breaking role for&hellip;</a></h4></li><li><h4 class="gk-nsp-link-header"><a href="http://wavenewspapers.com/book-corner-love-story-male-slave-master/" title="BOOK CORNER: A love story between male slave and master">BOOK CORNER: A love story between male slave and master</a></h4></li><li><h4 class="gk-nsp-link-header"><a href="http://wavenewspapers.com/bill-vaughans-tasty-clips-touched-angel-star-della-reese-unique-talent/" title="BILL VAUGHAN'S TASTY CLIPS: ‘Touched by an Angel’ star Della Reese had unique talent">BILL VAUGHAN'S TASTY CLIPS: ‘Touched by an Angel’ star Della&hellip;</a></h4></li><li><h4 class="gk-nsp-link-header"><a href="http://wavenewspapers.com/book-corner-love-sexuality-faith-examined-memoir/" title="BOOK CORNER: Love, sexuality, faith  examined in memoir">BOOK CORNER: Love, sexuality, faith  examined in memoir</a></h4></li></ul></div></div></div></div>		</aside>
						<!--[if IE 8]>
		<div class="ie8clear"></div>
		<![endif]-->
	</div><!-- end of the #gk-mainbody-columns -->
</div><!-- end of the .gk-page-wrap section -->	


<div id="gk-bottom2" class="gk-page widget-area">
	<div id="nav_menu-4" class="box  widget_nav_menu col6 nth1 last4"><h3 class="box-title">Sections</h3><div class="menu-footer-sections-container"><ul id="menu-footer-sections" class="menu"><li id="menu-item-1399" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1399"><a href="/">Home</a></li>
<li id="menu-item-1401" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1401"><a href="http://wavenewspapers.com/category/news/">News</a></li>
<li id="menu-item-1403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1403"><a href="http://wavenewspapers.com/category/sports/">Sports</a></li>
<li id="menu-item-1400" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1400"><a href="http://wavenewspapers.com/category/arts_and_entertainment/">Entertainment</a></li>
<li id="menu-item-1402" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1402"><a href="http://wavenewspapers.com/category/opinion/">Opinion</a></li>
<li id="menu-item-1409" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1409"><a href="http://wavenewspapers.com/category/news/obituaries/">Obituaries</a></li>
<li id="menu-item-1418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1418"><a href="http://wavenewspapers.com/category/photos/">Photos</a></li>
<li id="menu-item-1410" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1410"><a href="http://wavenewspapers.com/events/">Calendar</a></li>
<li id="menu-item-1417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1417"><a href="http://wavenewspapers.com/category/classifieds/">Classifieds</a></li>
</ul></div></div><div id="nav_menu-5" class="box  widget_nav_menu col6 nth2 last4"><h3 class="box-title">Services</h3><div class="menu-footer-services-container"><ul id="menu-footer-services" class="menu"><li id="menu-item-1408" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1408"><a href="http://wavenewspapers.com/about-us/">About Us</a></li>
<li id="menu-item-1405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1405"><a href="http://wavenewspapers.com/category/advertising/">Advertising</a></li>
<li id="menu-item-1436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1436"><a href="http://wavenewspapers.com/subscription-services/">Subscription Services</a></li>
<li id="menu-item-2593" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2593"><a href="http://wavenewspapers.com/submit-a-news-item/">Submit A News Item</a></li>
</ul></div></div><div id="text-32" class="box  widget_text col6 nth3 last4"><h3 class="box-title">Contact Us</h3>			<div class="textwidget"><h4>Los Angeles Wave</h4>
<p>
<strong>Phone Number:</strong> (323) 556-5720<br />
<strong>Address:</strong> 3731 Wilshire Blvd., Suite 840<br />Los Angeles, CA 90010
</p></div>
		</div><div id="search-4" class="box  widget_search col6 nth4 last4"><h3 class="box-title">Search</h3>
<form method="get" id="searchform" action="http://wavenewspapers.com/">
	<label for="s">Search</label>
	<input type="text" class="field" name="s" id="s" placeholder="Search" value="" />
	
	<input type="submit" id="searchsubmit" value="Search" />
</form></div>	<!--[if IE 8]>
	<div class="ie8clear"></div>
	<![endif]-->
</div>

	<footer id="gk-footer" class="gk-page">			
				
		<div class="gk-copyrights">
			© Copyright 2017, Los Angeles Wave, Los Angeles, CA.
					</div>
		
		
				
			</footer>
	
	
<div id="gk-popup-login">	
	<div class="gk-popup-wrap">
				    
			
		<form name="loginform" id="loginform" action="http://wavenewspapers.com/wp-login.php" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Log In" />
				<input type="hidden" name="redirect_to" value="http://wavenewspapers.com/street-beat-terms-development-south-l-need/" />
			</p>
			
		</form>		
			</div>
</div>

<div id="gk-popup-overlay"></div>
	
		
		
		
	<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/comment-reply.min.js?ver=4.8.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/themes/News/js/gk.scripts.js?ver=4.8.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/themes/News/js/shortcodes.typography.js?ver=4.8.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/themes/News/js/shortcodes.elements.js?ver=4.8.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/themes/News/js/shortcodes.template.js?ver=4.8.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/thickbox/thickbox.js?ver=4.8.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"http:\/\/wavenewspapers.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/wavenewspapers.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/wavenewspapers.com\/wp-json\/","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.8'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/themes/News/js/widgets/nsp.js?ver=4.8.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/themes/News/js/widgets/tabs.js?ver=4.8.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-includes/js/wp-embed.min.js?ver=4.8.4'></script>
<script type='text/javascript' src='http://wavenewspapers.com/wp-content/themes/News/js/gk.menu.js?ver=4.8.4'></script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-3').gslider({ groupid: 3, speed: 6000 });
}
});
</script>
<!-- /AdRotate JS -->

	
	</body>
</html>